Jump to content
Premed 101 Forums
xniper

OMSAS cannot submit application Error

Recommended Posts

1 minute ago, Acceptmenextcyclehowbowdah said:

No, but if this doesn't work out in the next 7 hours, I'm 100% jumping on a class action haha

You might want to read the fine print on the OMSAS page before doing anything. You're not entitled to a medical school application, and they do advise students to apply well in advance. 

Share this post


Link to post
Share on other sites

Okay, I submit my application at 0330. I was getting errors at first but then it went through. Now when I log in, it says that "application being processed". I guess that means it's all good? I'm so paranoid that I'll miss the extended deadline...even though I've submitted it already. 

Share this post


Link to post
Share on other sites

Can someone PLEASE confirm if you go an e-mail saying: TITLE: Your 2019 OMSAS application has been submitted. and then in the e-mail You have successfully submitted your application. Your OUAC/OMSAS reference number is 2019-XXXXX.

I then received an e-mail saying my payment was approved, etc. 

This was all at 3:20, apparently right after the site crashed. Now when I log into my OMSAS account I see this msg: 

My Fees Pending

Note: These fees may change depending on your choices and potential exemptions.

There was an error completing your request. Please contact the OUAC at 519-823-1063.

 

so just wondering if anyone who believes they submitted their application correctly and received the same e-mail, is seeing that msg when they log into their account? I submitted my application and then went to work thinking everything is fine..

Share this post


Link to post
Share on other sites

I'm getting this now

Document Tracking

 

We are currently processing your application.

Note: During the busy periods around deadline dates (January/February), it can take up to 2 weeks to process your application. Normally, it takes 1-3 business days.

Share this post


Link to post
Share on other sites

I submitted my application, but the website shut down right as I was about to pay. Now on the website it's saying my application has been submitted and I have submitted my payment but I never put in any payment info...anyone have this issue? 

Share this post


Link to post
Share on other sites
Just now, bival said:

I submitted my application, but the website shut down right as I was about to pay. Now on the website it's saying my application has been submitted and I have submitted my payment but I never put in any payment info...anyone have this issue? 

no didn't even get to that stage yet 

Share this post


Link to post
Share on other sites
4 minutes ago, bival said:

I submitted my application, but the website shut down right as I was about to pay. Now on the website it's saying my application has been submitted and I have submitted my payment but I never put in any payment info...anyone have this issue? 

did you get an e-mail? I was able to put in my information and I submitted everything - you should get 2 e-mail, one from OMSAS with your reference # & one from OMSAS saying your payment was approved.

Share this post


Link to post
Share on other sites
7 minutes ago, bival said:

I submitted my application, but the website shut down right as I was about to pay. Now on the website it's saying my application has been submitted and I have submitted my payment but I never put in any payment info...anyone have this issue? 

did this happen at around 3? or now?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...