Jump to content
Premed 101 Forums
Jummyneutrondexter

Queens technical issue during kira??

Recommended Posts

Just now, FBCforreal said:

yes. i dont know if we should bring it up, i wish i took the guaranteed interview next cycle

 

Yep, I also wish I took the guaranteed interview next cycle, I think I messed up real bad, LOL. 

Share this post


Link to post
Share on other sites

My test wouldn't continue after question 1 and the chat box was just a useless bot. Emailed for help and got nothing so I restarted my computer and it worked after that. I couldn't even press Submit on the feedback form for Kira at the very end

Share this post


Link to post
Share on other sites

I had a lot of technical issues! Halfway through the assessment, it told me that my assessment was complete. I wish Kira had a live chat option available (with a real human) rather than having to email them in the middle of the MMI. 

Share this post


Link to post
Share on other sites

Ugh I also had technical issues right from the start - my assessment also said I was complete after only the first question. Ended up closing my browser and re-doing a set-up in chrome incognito, which fixed it. The chatbot was super frustrating! 

Share this post


Link to post
Share on other sites
On 3/26/2020 at 12:54 PM, FBCforreal said:

im really considering sending them an email. my technical issues and the issues with kira itself (the long prompts were cut off under the camera view screen) made this interview straight up unfair

I found this awkward too, it was so hard to look back to check for clarification. 
I wasted time on a few questions trying to do this. 

Share this post


Link to post
Share on other sites

Hey, just putting it out there for those of you who experienced technical issues and still went through the process calmly shows your ability to keep cool under pressure (a really important quality for a physician IMO!) I would expect evaluators to take this sort of thing into account and interpret this as a strength in your candidacy.  

Share this post


Link to post
Share on other sites
On 3/26/2020 at 1:03 PM, DaniCalifornia said:

Ugh I also had technical issues right from the start - my assessment also said I was complete after only the first question. Ended up closing my browser and re-doing a set-up in chrome incognito, which fixed it. The chatbot was super frustrating! 

I had this exact same issue and resolved it the same way. Thankfully it didn't manage to stress me out, but I can see how it would potentially frazzle someone enough to throw them off their A game. I hope you still managed to rock the rest of your interview! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...